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Scope of work

Demonstrate how to implement the data multiplexer over the UART
(USB) interface

After configuring the OneEye UART interface, a data multiplexer is created.
OneEye is used to visualize the signal values.
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Introduction

» OneEye is a GUI that enables the creation of interactive Graphical User Interface. Graphical
elements can be drag from a toolbox and drop onto the GUI. The behavior of the created
GUI can be customized. Different communication interfaces like UART, Ethernet, CAN, DAS
can be used to interact with the embedded system

» SyncProtocol / ProtocolBB is a synchronous protocol that enables data streaming between
the target microcontroller and OneEye. It enables to open multiple communication channels,
provide packet acknowledge and packet checksum. Data are transported within a message
with a message ID and a message payload. See the OneEye help for more information.

Single frame
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> Note: It is recommended to go through some of the basic tutorials listed in the help
embedded in OneEye (Menu: Help -> OneEye help). This enables a quicker ramp-up in the
OneEye concept and ensures a nice journey with OneEye
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Hardware setup

This code example has been developed for the
board KIT_A2G_TC375 LITE.

The board should be connected to the PC
through the USB port ( 1

www.infineon.com/
AURIX-lite-Kit
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Configuration overview

In this configuration two C struct are used to exchange data over the COM port between the microcontroller
and OneEye.

In OneEye, two signals bb.in and bb.out are used to connect the COM port data stream to the BB protocol.
The BB protocol is configured to open a channel reserved for the data multiplexer. This channel connects to
the Mux-Demux widget using the mux.in and mux.out signals. The Mux-Demux widget connects to a slider
with the command.max signal and a Graph with the status.signalA and status.signalB signals.

BB protocol ‘

Slider [command.max

BB Data

. Multiplexer
Multiplexer Protocol P
Protocol channel
channel

Onekye Micro-controller
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Implementation - AURIX

Enabling the OneEye library

The OneEye library must be enabled by adding the following line to Ifx_Cfg.h:
#define IFX_OE_AL_USE_AURIX_ILLD

Configuring the data multiplexer

A OneEye BB protocol client (Ifx_Oe_SyncProtocol_Client) is an object that enables raw massage data
transmission using the BB protocol (Ifx_Oe_SyncProtocol).

The OneEye BB protocol client is initialized with initDataMultiplexer() / Ifx_Oe_SyncProtocol_addClient().
The ifx_oe_syncprotocol.h file can be found in the Libraries\OneEye directory.
Configuring the UART communication

The UART communication is initialized with the function initUart(), which also initializes the BB protocol.

In the infinite while loop, the function processUart() executes the SyncProtocol.
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Implementation - AURIX

Receiving data from OneEye

Receiving data from OneEye is done within processDataMultiplexer(). The client is periodically checked for
Incoming messages using the Ifx_Oe_SyncProtocol_isMessageAvailable() passing a pointer to the BB client as
parameter.

To decode the received data, a message buffer must be acquired first with the function

Ifx_Oe_SyncProtocol _getReadMessageBuffer(). The function takes a pointer to the BB client as input parameter,
and pointers to a message ID, a message payload buffer and a message length as output parameters. Then the
message payload pointer is cast to the C struct type that defines the data. Finally the data are readout from the C
struct and the message is released using Ifx_Oe_SyncProtocol_releaseReadMessageBuffer().

Sending data to OneEye

Sending data to OneEye is done within processDataMultiplexer(). Data are send periodically (100ms). The timing is
ensured using the Ifx_Oe_Time_isDeadLine() and Ifx_Oe_Time_add() functions.

To send data, a message buffer must be acquired first with Ifx_Oe_SyncProtocol_setSendMessageBuffer(). The
function takes a pointer to the BB client, the message ID and the message size parameters. Then the message
payload is cast to the C struct type containing the data and the C struct is filled with data. Finally, the message is send
using Ifx_Oe_SyncProtocol _sendMessage() passing the message pointer as parameter.

Note: it is important to ensure the struct member offset and size to enable proper encoding / decoding by OneEye.
This memory mapping is specific to the CPU data alignment and compiler. For Hightec compiler, the
__attribute__ ((_packed_)) is added to the DataStreaming_Data 0 and DataStreaming_Data 1 struct definition.
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Implementation - AURIX

Configuring the signal generator

A signal generator is used to provide the user with some value to read / write. The signal generator does
nothing more than incrementing two signals, signalA and signalB, stored in the structure g_signalGenerator
up to a maximum value before resetting them.

The initialization of the signal generator is done with initSignalGenerator ().

Running the signal generator

The signal generator is executed in the background loop every 1ms with processSignalGenerator(). To
ensure the timing, a deadline variable is periodically updated with Ifx_Oe_Time_add() to obtain the 1ms
period.
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Run and Test

> After code compilation, flash the device using the Flash button @@ to ensure that the
program is running on the device

»  For this training, the OneEye application is required for visualizing the values. OneEye can
be opened inside the AURIX™ Development Studio using the following icon:

File Edit Source Refactor Navig'ﬂearch Project Debug Window Help
| )" E CKIE E E '.:} |:?:| #ﬁl - .) - | - ’l‘f::l l::_& {:j - -
|
v
Onekye — O x

> Clicking the OneEye

icon automatically
opens the OneEye
configuration for the
active project. If no
configuration exists, it
is created by AURIX™
Development Studio

OneEye Version 2.46.0
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Implementation - OneEye

In this training, the OneEye configuration is provided inside the Libraries folder. The following steps are
needed to configure the oscilloscope from a brand-new configuration.

Setup OneEye for editing

Select the OneEye menu “Options -> Edit mode” (if not already checked) to enable the edit mode.

Select the OneEye menu “View -> Browser box”, “View -> Property box” , “View -> Tool box” (if not
already checked) to display the browser, property box, and tool box. Note that the box can be moved around.

Tool box a8 x Property box B8 x

Elaarsauge
Check Box

Path QObject Title

configuration
debugBox

OneEye Version 2.46.0 1105, 670
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Implementation - OneEye

Removing the default DAS interface

When the OneEye configuration is created by ADS, it is already setup with a DAS interface.
Select the interface in the Browser box and delete it with “right click and remove” as it is not required in

this example.

OneEye - m} X
File Options View Help
Tool box T X Property box g %
~
H Plugin Com Port: DAS
pacatas plugin PCom_DASHDAS

server-host-address |localhost

Check Box
server-name UDAS
O connect
clockees f [eos ]
N

Combo Box
system-key {ADS}

@ Dial
i Graph
i Graph Channel

Goan &
< >
Browser box g X
All ~
Path Object Title  *
signals
ayo
interface interface.
DAS INterrace.
configuration
[P NP b
< >

OneEyeVersion 2.46.0 1105, 670
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Implementation - OneEye

Configuring the UART interface: Signal creation
The first step is to create 2 signals to connect the received and transmit data over the UART.

Create a signal group and set its name property to bb.

Onekye - O X
File Options View Help
Browser box e x| Property box g x
Al v "
Signal: group
Path Ohbject Title { name |bb |
layout offset
configuration sccess
model-update-value-enabled O
user-data I:I
send-get-request ]
on-updated I:I
include-path l:l
include-as-read-only
< > Enum values
Tool box Browser box Match events hd

OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Add two signals of type char into the bb group, name them in and out, and set their title property to
respectively BB in and BB out.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v "
Signal: char
Path Object Title pf name [in |
“ signals
h
“ bb group type char
offset
out char BBout
configuration model-update-value-enabled O
P title [BBin |

send-get-request ]

on-updated

Enum values

Match events

< >

Connections

Tool box Browser box

OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: COM port
Right click in an empty area of the Browser box, and select Add child -> Interface. Then right click on the

created interface and select Add child -> com. Select the com item and set its device property to the COM
port connected to the AURIX board. Set the baudrate property to 115200 and click connect.

The COM port is now opened and ready for communication.

OneEye

File Options View Help

Browser box g X Property box g X

All w
Plugin Com Port: com

Path Object Title plugin PCom_Corezcom
“ signal
signats device COM17
bb group
layout »] baudrate 115200
~ interf, COM.COM1T
interface connedt

;ﬁam COM CORMIT
contiguration

< >

Tool box Browser box

OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: Transmit stream

Right click on the interface in the Browser box, and select Add child -> dataMessageHandler. Then right
click on the created dataMessageHandler and select Add child -> message to create a message item.
Configure the message with the id=0xFE, interval=0.001, send-on-new-data checked, dir=tx, stream
checked.

OneEye

File Options View Help

Browser box g X Property box g X
All w
Message: message
Path Object Title id |oxFE |
> signal
S interval [0.001 |
layout P
v interface COM.COM1T send-on-new-data
v dataMessageHandler dir x -
¥ MESSaEE irn
field bb.out type extended hd
¥ message 0xFF
length 0
field bb.in T = | |
<
com COM.COM1T P stream |
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Right click on the message, and select Add child -> field.
Configure the field with name=bb.out, bit-pos=0, buffer=512.

Now, data will be transmitted over the UART each time the bb.out signal is written with some data.

Onekye

File Options View Help

Browser box JF X Property box 5 X
All ~
Message field:  field
Path Object Title name bb.out ]
> signal
signals Pl bit-pos |O |
layout
v interface COM.COM17 buffer |512 |
w
dataMessageHandler PR ket O
¥ Message OxFE
I field : oot
“ message 0xFF
field bb.in
com COM,CoM17
configuration
€ >
Toolbox  Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Configuring the UART interface: Receive stream

Right click on the dataMessageHandler and select Add child -> message to create a second message item.
Configure the message with the id=0xFF, interval=-1, dir=rx, stream checked.

OneEye

File Options View Help

Browser box JF X Property box 5 X
All -
Message: message
Path Object Title id |oxFF |
y
signals interval |-1 |
layout >
v interface COM.COM1T send-on-new-data [
v dataMessageHandler dir |rx vl
¥ message 0xFE
field bb.out type |extended v
b e
mes.s..age i length |O |
field bb.in
com COM.COM1T PLstream |
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465
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Implementation - OneEye

Right click on the message, and select Add child -> field.
Configure the field with name=Dbb.in, bit-pos=0.

Now each time data are received over the UART, the bb.in signal will be updated.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v|
Message field:  field
Path Object Title name bh.in + -
: >
>
signals bit-pos |'U |
layout
v interface COM.COM17 buffer lo |
v dataMessageHandler buffer-as-pakeet 0
¥ message 0xFE
field bb.out
¥ Message 0xFF
I field : derbrsier
com COM,.COoM17
configuration
£ >
Tool box Browser box
OneEye Version 2.48.0 937, 465




Implementation - OneEye

Configuring the UART interface: Push button
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Drag and drop a pushButton widget from the toolbox onto the layout, configure it with title=Setup Serial

Interface, on-click={show.connection.ui}.

Communication interface setup ? X
Clicking the button now shows the COM port configuration window.
Plugin Com Port: com
plugin PCom_Caoretcom
OneEye
> device COM17
File Options View Help
baudrate 115200
Browser box g X Property bo
connect
All -
Plugin w
Close
- T [eex ]
signals .
Pr— L .
pushButten I = : up Se data-out I:I +
interface COM.COM17
configuration auto-connect I:I 2 -
title Setup Serial Interface
Setup Serial Interface user-data | |
enabled defing¢d-by-connection w
visible yES W
update-method on-new-data w
style-sheet
i = Pl on-click |{5how.connection.ui} |I v
Tool box Browser box < 2
OneEye Version 2.48.0 937,472




Implementation - OneEye

Configuring the BB protocol
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Right click in an empty area of the Browser box, and select Add child -> protocolEngine. Then right click on
the created protocolEngine and select Add child -> protocol-core-bb. Connect the BB protocol stream to
the bb.in and bb.out signals by setting respectively the data-in and data-out properties. Set the name
property to BB-core. And set the timeout to 2000 ms so that frames are dropped after 2 seconds in case the

microcontroller is not answering.

OneEye

File Options View Help

Browser box

All

Path
signals
layout
interface

Object Title

COM.COM1T
.BB-core

~ protocolEngine
Iprotocol—corebb =

configuration

€

Tool box Browser box

OneEye Version 2.48.0 937,472

Setup Serial Interface

Property box
Plugin protocol core; protocol-core-bb
name |BB—core
plugin PProtocol_Corenbb
»1 data-in |bb.in
data-out |bb.out
timeout |2000
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Implementation - OneEye

Configuring the Data multiplexer: signals creation

Create a signal group under the signals root and set its name property to mux.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v| A
Signal: group
Path Object Tit ::name [mux u
“ signals
e rou
> bb group typ SEH
mux 4= offset |ﬂxﬂ |
¥ layout .
pushButton  Setup SerialInte... Sef] Shress |I’E3E|—WI"Il£‘ vl
> interface COM.COM1T model-update-value-enabled O
> tocolEngi BB-c
pro {_,CO r?gme ore Setup Serial Interface title | |
configuration
user-data | |
send-get-request ]
on-updated | |
include-path | |
include-as-read-only
< * Enum values
Tool box Browser box Match events hd
OneEye Version 2.48.0 1030, 465
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Implementation - OneEye

Add two signals of type char into the mux group, name them in and out, and set their title property to
respectively Mux in and Mux out.

Onekye - O X
File Options View Help
Browser box g X Property box g X
Al v "
Signal: char
Path Object Tit { name [in u
“ signals
€ char
> bb group tvp
h-d group offset |ﬂxﬂl |
I L —
out char Mu ACCess | read-write ~ |
> layout model-update-value-enabled O
> interf COM.COM1T
interiace SetrrSeroHinterie ——p{ iitle [Muxin u
» protocolEngine .BB-core
configuration user-data | |
send-get-request ]
on-updated | |
Enum values
Match events
£ >
Connections
W
Tool box Browser box
OneEye Version 2.48.0 1030, 465
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Implementation - OneEye
Creating signals to send commands to the AURIX
Create a signal group under the signals root and set its name property to command.

Add two signals of type float into the command group, name them max and increment, and set their title
property to respectively Max and Increment.

Onekye - O X
File Options View Help
Browser box g X Property box g X
All w ~
Signal: float
Path Object Title { name [max u
v o
signals type float
> bb group
7 mux group unit | |
v command group
max float Max offset |ﬂxﬂ |
increment float Increment S TETT e mree o
> layout
Setup Serial Interface
> interface COM.COM1T7 E default o |
3 )
protocolEngine .BB-core min |u |
configuration
max |ﬂ |
model-update-value-enabled O
{ title [Max u
user-data | |
< > send-get-request O
on-updated | | v
Tool box Browser box
OneEye Version 2.48.0 1030, 465
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Implementation - OneEye

Creating signals for the received data

Create a signal group under the signals root and set its name property to status.

Add two signals of type float and sint32 into the status group, name them signalA and signalB, and set their
title property to respectively Signal A and Signal B. Note that the data type must match the one defined in
the AURIX C struct DataStreaming_Data_O.

Onekye - O X
File Options View Help
Browser box g X Property box g X
All w "
Signal: float
Path Object Title name |5ignaLA |
v o
signals type float
> bb group
7 mux group unit | |
> command group
¥ status group offset |ﬂxﬂ |
signald  float Signal & S TETT read-only o
signalB ___sint32 Signal B ’
v loyout —— Setup Serial Interface default |0 |
pushButton  Setup Seri... Setup Serial min |u |
» interface COM.COM17
» protocolEngine  .BB-core max |ﬂ |
onfiedalion model-update-value-enabled O
title |signal A |
user-data | |
< > send-get-request O
on-updated | | v
Tool box Browser box
OneEye Version 2.48.0 1030, 465
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Implementation - OneEye

Create the slider widgets to send command to the AURIX

Drag and drop a slider widget from the toolbox onto the layout, set the slider properties auto-connect to
command.max. and max to 1200,

Onekye - O X

File Options View Help

Browser box g X Property box g X
Al v| A
Plugin widget: slider
Path Object id
> signal
signats data-in command.max +
~ layout
i | Setup Serial Interface data-out command.max =
slider Max 1 [
> interface COM.COM17 { auto-connect |command.max | | <f | [ - |
» protocolEngine  .BB-core title | |
configuration
user-data | |
enabled |deﬂned—by—mnnectinn - |
visible |yes V|
layout | harizontal e |
update-method |Dn-new-data V|
style-sheet
Maxﬂ' 1200
] 1 1 1 1 1 1 1 1 1 1
min o
| max 1200 I
< > tick-count |100 |
page-size 10 W
Tool box Browser box | |
OneEye Version 2.48.0 1112 558
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Implementation - OneEye

Create the graph widgets to display the signals value

Drag and drop a graph widget from the toolbox onto the layout.

Onekye - O X
File Options View Help
Browser box g X | Setup SerialInterface | Property box g X
|'ML vl Maxﬂ' 1200 "
! ! ! ! ! ! ! ! ! ' ! Plugin widget: graph
itle Update i Control id | |
O | S title | |
etup Serial Inte... Run/Stop user-data | |
enabled |deﬂne{|—by—mnne€tl’nn - |
visible |3re.=. V|
style-sheet
buffer-depth |6000 |
multi-channel |
legend-pos | top ~ |
division-x |1'D |
g 2 division-y |1-0 |
— [r—— X 15/Div 0.1724145 | control || Info | Hide | offsety s | o~
OneEye Version 2.48.0 1112 465




Implementation - OneEye

Create the graph widgets to display the signals value
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Drag and drop a Graph Channel (channel) widget from the toolbox onto the layout, set the channel
properties auto-connect to status.signalA, unit-per-division-y to 200, and color to green. Repeat the
operation for a second channel and set the channel properties auto-connect to status.signalB, and color
to black.

Onekye - O X
File Options View Help
Browser box & Setup Serial Interface Property box g X
All maxoll 1200 ~
! ! Plugin widget: channel
Path Object 0: Signal A& Control id |
signals ¥: 200 [Div data-in tatus.siznal
¥ layout ST status.signalA
- I -
pushButton  Setup Seri... 1: Signal B ] auto-connect |5tatu5.5|gnalA I +
: [
slider Max ¥ 200 [Div Ryfn/Stop ]
v g title | |
channel  Signal A sETkE | |
channel  Signal B
interface COM.COM1T enabled defined-by-connection ~
protocolEngine .BB-core e |5 |
configuration
pos-y |20 |
pos-vit [4nn ]
Iunit—per—di\rision—}r 200 I
pos-h
pen-width 1
farm:
= = Icolor green l ~
farmi -
Toolbox | Erowser box X: 15/Div 0.1143435 Control Info Hide format-fill-char A

OneEye Version 2.48.0 1112 465




Implementation - OneEye

(infineon

Create the muxDemux widgets to connect the BB protocol to the graph and slider widgets

Drag and drop a Mux-Demux (muxDemux) widget from the toolbox onto the layout, set the muxDemux
properties data-in and data-out to respectively mux.in and mux.out.

OneEye

— O X
File Options View Help
Browser box & Setup Serial Interface Property box g X
All maxoll 1200
! ! Pluginwidget: muxDemux
Path Object 0: Signal A& Control id |
> o5 L : 200 [Di
signats [oiv data-in muin +
~ layout Reset zoom
pushButton  Setup Seri... 1: Signal B data-out + -
: [
slider Max ¥ 200 [Div yuising
5 title
.
I muxDemux  Muxin | sETkE | |
* interface .
» protocolEngine  .BB-core visible yes ~
configuration header-enabled [ ]
key-length 4
key 0x0
h
£ >
X: 15/Div 0s Control Info Hide

Tool box Browser box Muxin

OneEye Version 2.48.0 1112 465
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Implementation - OneEye

Right click on the muxDemux widget in the browser box, and select Add child -> muxDemuxMessage, set
the muxDemuxMessage properties id to 0x4000 and dir to demux to decode received messages.

Onekye - O X
File Options View Help
Browser box = Setup Serial Interface Property box g X
All | [ maxol® 1200
! ! ! ! ! ! ! ! ! ! ! Mux-Demux message: muxDemuxMessage
Path Object 0 Signal A h contral id 04000
> o5 - i
signals ¥: 200 /Div dir demux »
~ layout Reset zoom
pushButton Setup Serial Inte 1: Signal B length 32
]
slider Max ¥i 200 /Div —ETE
> graph
v )
I muxDemuxMessage  0x4000 f
v interface COM.COM17
> dataMessageHandler
com COM.COM17
» protocolEngine .BB-care
configuration
.
£ >
X 15/Div 0s Control Infa Hide
Tool box Browser box Muxin
OneEye Version 2.48.0 1112 465
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Implementation - OneEye

Right click on the muxDemuxMessage in the browser box, and select Add child -> muxDemuxField, set the
muxDemuxField properties name to status.signalA, bit-pos to 0.

Repeat the operation for a second signal and set its properties name to status.signalB, bit-pos to 32.

Note: the status.sighalA and status.signalB signal size (32 bits), type (float / sint32) and offset (0 / 32) must
match the data member signalA and signalB of the C struct DataStreaming_Data_ 0.

OneEye

File Options View Help

Browser box & Setup Serial Interface Property box
All | [ maxol® 1200
! ! Mux-Demuxfield: muxDemuxField
Path Object Control name status.signalA +
signals >
v layout Resetzoom EEE |0
ushButton Setup Serial Inte LG send-on-new-data
p. P L S|gnaI_B Run/Sto
slider Max Yi 200 /Diy
graph Field size (bit): 32
¥ muxDemux Muxin
v rruxDemuxMessaEe (000
muxDemuxField status.signald
muxDemuxField status.signale
interface ™ OO
protocolEngine .BB-core
configuration
£ >
X 15/Div 0.255 Control Info Hide
Tool box Browser box Muxin
OneEye Version 2.48.0 1112 465
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Implementation - OneEye

Right click on the muxDemux widget in the browser box, and select Add child -> muxDemuxMessage, set
the muxDemuxMessage properties id to 0x4001 and dir to mux to encode and send messages. Set the
length property to 4 bytes, which corresponds of the size of the C struct DataStreaming_Data 1.

Onekye - O X
File Options View Help
Browser box = Setup Serial Interface Property box g X
All | [ maxol® 1200
! ! ! ! ! ! ! ! ! ! ! Mux-Demux message: muxDemuxMessage
Path Object 0 Signal A Y control id |0xa001 |
> signals ¥: 200 /Diy dir
~ layout Reset zoom
pushButton Setup Serial Inte 1: Signal B length
: ]
slider Max Yi 200 /Diy it e
> graph
¥ muxDemux Muxin
I muxDemuxMessage Gx-iml.l
> interface COM.COM17
» protocolEngine .BE-core
configuration
.
£ >
X 15/Div 0s Control Info Hide
Tool box Browser box Muxin
OneEye Version 2.48.0 1112 465
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Implementation - OneEye

Right click on the muxDemuxMessage in the browser box, and select Add child -> muxDemuxField, set the
muxDemuxField properties name to command.max, bit-pos to 0, and check send-on-new-data.

Note: the command.max signal size (32 bits), type (float) and offset (0) must match the data member max or
the C struct DataStreaming_Data 1.

Onekye - O X
File Options View Help
Browser box = Setup Serial Interface Property box g X
All | [ maxol® 1200
! ! ! ! ! ! ! ! ! ! ! Mux-Demuxfield: muxDemuxField
Path Object "0: Sighal A b Control name command.max +
> signals ¥: 200 /Diy .
v layout Neeelennm bit-pos |0
ushButton Setup Serial Inte| o send-on-new-data
p. P I: S|gnaI_B Run/Stdp
slider Max Yi 200 /Diy
» graph Field size (bit): 32
¥ muxDemux Muxin
> muxbDemuxMessage Ox2000
¥ muxDemuxMessage 0x4001
l muxDemuxField command.max
* int (3 =
» protocolEngine .BB-care
configuration
\
£ >
X 15/Div 0s Control Info Hide
Tool box Browser box Muxin
OneEye Version 2.48.0 1112 465
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Implementation - OneEye
Connect the Mux-Demux widget to the BB protocol
Right click on the protocol-core-bb and select Add child -> target. Select the target item and set local-port

and remote-port to 1 to match the AURIX settings, set signal-in=mux.out, signal-out=mux.in, and forward
checked.

Onekye - O X
File Options View Help
Browser box g X Setup Serial Interface Property box g X
All v macl® 1200
] 1 1 1 1 1 1 1 1 1 1 Targf_"t: target
Path Object "0: Signal A Control local-port |1 |
> signals ¥: 200 /Di
> layout Reset z00m remote-port |1 |
> interface COM.COM17 1: Signal signal-in |mux.out |
: Signal B g E
¥ protocolEngine .BE-core ¥ 200 /Di R i -
hd protocol—corebp_m__ signal-out |mux.|n |
‘target ———— STt forward
configuration send-parent-value 1
£ >
¥: 15/Div 9.64602s Control Info Hide
Tool box Browser box Muxin
OneEye Version 2.48.0 1112 465




Implementation - OneEye

Test the data multiplexer interface
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Save your configuration with CTRL+S and, exit the edit mode with the OneEye menu “Options -> Edit mode”

to only see the GUI.

Restart the AURIX software.

Move the slider cursor ' to change the max value and affect the generated signals value.

OneEye

File Options View Help

Max0 :

Setup Serial Interface

0: Signal A
¥: 200 [Div
Value: 300

1: Signal B
¥: 200 Div

1 | value: 800

\H\‘

X 1s/Div

Muxin

2.10534 5

IlZl}ﬂ

Control

Resetzoom

Run/Stop

Control Info Hide

OneEye Version 2.48.0
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References

»  AURIX™ Development Studio is available online:
»  https://lwww.infineon.com/aurixdevelopmentstudio

%&%ﬂ > Use the ,Import..." function to get access to more code examples.

> More code examples can be found on the GIT repository:
»  https://github.com/Infineon/AURIX_code_examples

v

For additional trainings, visit our webpage:
https://www.infineon.com/aurix-expert-training

v

~

For questions and support, use the AURIX™ Forum:
https://www.infineonforums.com/forums/13-Aurix-Forum

v
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IMPORTANT NOTICE

The information given in this document shall in no
event be regarded as a guarantee of conditions or
characteristics (“Beschaffenheitsgarantie”).

With respect to any examples, hints or any typical
values stated herein and/or any information
regarding the application of the product, Infineon
Technologies hereby disclaims any and all
warranties and liabilities of any kind, including
without limitation warranties of non-infringement
of intellectual property rights of any third party.

In addition, any information given in this
document is subject to customer’s compliance
with its obligations stated in this document and
any applicable legal requirements, norms and
standards concerning customer’s products and
any use of the product of Infineon Technologies in
customer’s applications.

The data contained in this document is-exclusively
intended for technically trained staff. It is the
esponsibility of ustomer’s technical
departments to—evaluate the suitability of the
product for the intended application and the
completeness of the product information given in
this document with respect to such application.
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For further information on the product,
technology, delivery terms and conditions and
prices please “contact your nearest Infineon
Technologies office (www.infineon.com).

WARNINGS
Due to technical requirements products may
contain dangerous substances. For information
on the types in question please contact your
nearest Infineon Technologies office.

Except as otherwise explicitly “approved b
Infineon Technologies in a written\ document
signed by authorized representatives of\Infineon
Technologies, Infineon Teehnologies’ products
may not be used in—any applications where a
failure of the-product or any consequences of the
use thereof can reasonably be expected to result
n personalinjury.
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